App doesn't find my home Wifi network

Unboxed today. Downloaded app on Google Play (newest version). Did not connect. Followed instructions for USB firmware upgrade, appeared to be successful. Attempting to “add new device” in the app and the only device it picks up is “OasisMini”. I restarted my router, I reset the Oasis (hold button for 25 seconds) I held the button for 3 seconds, and plugged the Oasis in so it’s 5 feet away from my router. It still doesn’t give me the option to add my home network. What else can I try?

1 Like

@jeanfi Just a few questions for me to understand your problem.

  1. What page you get an error?
  2. Can you please send a screenshot of the error message?

The steps to connect are:

  • Click on Add New Device
  • Accept OasisMini connection (need to authorize location)
  • Select your home network
  • Put password

Please make sure your phone is connected to the wifi router you will add your Oasis Mini.

Let me know if that works

1 Like
  1. the error comes on the Available Devices page when I click the "Add New Device button.
  2. Screenshots attached

Steps

  • I can Click on Add New Device
  • I authorized Oasis Mini to use my location while using the app
  • My home network is not a choice. All I see is “OasisMini”
  • I can’t choose my home network to be able to enter a password.

My phone is connected to the WiFi router that will also have the Mini




1 Like

@jeanfi We are investigating your issue. It is first time we have seen this problem.

Would you be able to test in another phone? I want make sure the issue is not related to the phone version.

Thank you

1 Like

FWIW, I have a Google Nest Mesh network and I could not connect the Oasis to the 5GHz band wifi network, and had to fall back to the 2.4GHz band guest wifi network in order for it to work. Not sure if that’s helpful or not in this case.

2 Likes

Hmm, I’m surprised you were even able to see the 5ghz band. We try to exclude those from the wifi list because Oasis Mini does run on 2.4ghz as you’ve noticed. I’ll mention this to the devs

1 Like

Might be why it behaved that way… the first gen nest WiFi runs a mixed 5/2.4GHz channel for the main SSID I think, while the guest network is restricted to 2.4GHz by default. Interesting!

1 Like

Tested on another phone and had the same issues.
After reading @solfrost advice about the home vs guest network I created a guest network (didn’t have one), restarted/redid everything (router, phone, Oasis, uninstall/reinstall app, re-did the USB firmware upgrade), and am still getting the same error. FWIW, this is the final line on the USB upgrade Outbox code:
Erase size 0, blocks 0, block size 0x4000, offset 0x0000, encrypted no
Done!
To run the new firmware please reset your device.
------------------------------------------------------------

My “your device” I assumed it meant the Oasis so I pressed the button for 25 seconds and still no success. Does “your device” mean my computer? Or possibly my router?

1 Like

I don’t know all of the button-press actions, but I think the time intervals determine what pressing the button does, so maybe try a 5 second press first, then 10 seconds, 15, 20, and so on, to see if any of the other intervals have a positive effect on the issue?

I believe there was supposed to be a key or legend, that spells out each interval’s utility, but I haven’t been able to find it yet.

For some reason, 5 seconds is what I recall was suggested for a reset, but it could also be a connection reset. I’m sure someone else will chime in with it. :slight_smile:

1 Like

After searching the forum a bit, I found someone mentioned that even a 1-second press has a function… here’s that info:

“Reset button functionalities, including quick reboot (1S), WiFi settings reset (5S), full machine reset(10S), and arm position adjustment(20S).”

I hope this helps until real help comes along.

1 Like

That is so helpful, I’ll try all those combinations! Where in the world did you find that? My Oasis didn’t come with a user manual, was it supposed to?

1 Like

We’ll have an online manual up soon in addition to an official support page for the reset button functions!

To reset the device after the firmware upgrade, all you need to do is unplug it and plug it back in. We’ll work on making the text more clear. Were you able to get this working after the web firmware upgrade?

1 Like

Not yet. Im spending about 10 minutes a day fiddling with it, but no luck yet. Still hasn’t found my wifi network. Looking forward to the manual for some extra tips I haven’t tried yet.

1 Like

I appreciate the fiddling you’ve done! Do you have a ticket open? Our support team can help with this. https://support.grounded.so

1 Like

I just did, thanks for pointing me in that direction.

2 Likes

I"m having EXACT same issues.